INVALID_CROSS_REFERENCE_KEY

Article ID: 54720

Article Type: Troubleshooting

Last Modified:

An error appears in the Job details during a Salesforce restore operation.

Symptoms

One of the following errors appear in the Job details during a restore operation:

Causes

The user profile that is configured for backup or restore does not have the correct record type (id 0123z000000OGncAAG )  assigned to the Asset object. Please go through the link to set it.

Resolution

Do the following steps to enable the RecordType on SFDC:

  1. Log on using a System Administrator profile on SFDC.
  2. Click Setup under the username on SFDC.
  3. Click Manage Users under Administrative Setup section
  4. Enter the profile that needs to be added to. To enter, click the profile but do not click on Edit
  5. Scroll down to the* Record Type Settings *section and click edit for the Asset object. Select the specific record type in the list Available Record Types and add it to Selected Record Types.
  6. Save the changes.
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