VMware Backup Completes with Warning or Error: "Unable to quiesce guest file system during snapshot creation"

Article ID: 63085

Article Type: Troubleshooting

Last Modified:

If a backup of a VMware VM fails to quiesce the guest file system, the backup continues as a crash-consistent backup. In 11.22 and previous releases, the job completes with errors. In 11.23 and later releases, the job completes with warnings.

Symptoms

In 11.22 and earlier releases, if a backup of a VMware VM fails to quiesce the guest file system, the backup completes with an error. In 11.23 and later releases, if a backup of a VMware VM fails to quiesce the guest file system, the backup completes with a warning. The error or warning message appears as follows:

vm_name Failed: Unable to quiesce guest file system during snapshot creation

In this situation, the backup runs as a crash-consistent backup.

Causes

This warning or error can occur for the following reasons:

  1. For a Windows guest VM, the Virtual Disk service did not start in the Windows guest operating system.
  2. VMware Tools are not installed or are not up to date on the guest VM.
  3. The backup ran at a time of high activity for the guest VM.

To get more information about the warning or error, you can review the events associated with the backup of the VM in vCenter.

Resolution

To resolve this issue, perform the following steps:

  1. Start the Windows Virtual Disk service for the guest VM as described in the VMware KB article “msg.snapshot.error-QUIESCING-ERROR” in vCenter Server (2069952).
  2. On the guest VM, verify that VMware Tools are installed and up to date.
  3. Retry the backup at a time of lower activity for the guest VM.
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