Metadata Collection Fails for Virtual Machine Backups
Article ID: 63536
Article Type: Troubleshooting
Last Modified:
If the metadata collection process fails during a VM backup, normal streaming backup continues without collecting the metadata. However, this warning might indicate that some disks are not initialized or the VM might not support metadata collection.
Symptoms
In 11.22 and earlier releases, the metadata collection phase of a VM backup fails, and the backup job reports as Completed with errors. In 11.23 and later releases, the metadata collection phase of a VM backup fails, and the backup job reports as Completed with warnings.
Causes
The metadata collection phase of a VM backup might fail because of the following reasons:
The VMs might contain disks that are not initialized.
The hypervisor does not support the collection of metadata. To view a list of hypervisors that support metadata collection, in the Commvault Documentation, see Metadata Collection.
Resolution
You may have encountered a VM disk that is unsupported for Metadata collection. It is recommended you use the compatible file recovery enabler method to enable file recovery from VM backups. This method enables faster backups and allows for more recovery scenarios of VM guest files.
To resolve this issue, perform any of the following tasks:
Disable metadata collection on the subclient to leverage the file recovery enabler method instead.
In the CommCell Console, go to the VSA subclient where the backup job ran.
Right-click the subclient, and then select Properties.
On the Backup Options tab, clear Collect File Details.
To collect metadata for file-level restore operations, on the VM client computer, initialize the disks before running a new backup operation. For instructions about initializing disks, on the Microsoft Documentation website, see Initialize new disks.