QUERY_TIMEOUT

Article ID: 64594

Article Type: Troubleshooting

Last Modified:

Errors are occurring during the emptiness check or when objects are downloaded to the local cache for a Salesforce backup operation.

Symptoms

The SFEngine.log contains a QUERY_TIMEOUT error.

Causes

Objects are very large in size and require additional time to process, but Salesforce has a query timeout limit.

Resolution

If the QUERY_TIMEOUT error occurs during the emptiness check or the download operation, contact Salesforce to resolve the issue. You can provide Salesforce with the queries that Commvault uses for the emptiness check and the download operation:

select id from object LIMIT 1

select id,field1,field2,all_individual_fields from Object where systemmodstamp <=current_time

After the QUERY_TIMEOUT error occurs, the Commvault job continues and processes the other objects in the job. To exclude large objects from backup operations, see Excluding Salesforce Objects from a Backup Operation.

1 Commvault Way, Tinton Falls, NJ 07724 Sitemap | Legal Notices | Trademarks | Privacy Policy
Copyright © Commvault | All Rights Reserved.