INACTIVE_OWNER_OR_USER

Article ID: 67596

Article Type: Troubleshooting

Last Modified:

Performing a Salesforce restore operation that includes an object record with an inactive record owner produces an error.

Symptoms

The restore operation fails for a standard or custom object in Salesforce and the following error appears:

Custom_object__c record a0S3M000000DoGlUAK was not inserted. Error message: INACTIVE_OWNER_OR_USER:operation performed with inactive user [0053M000000ln0M] as owner of 01I3M0000008k25:--

Causes

The restore operation fails because an object record in Salesforce has an inactive record owner.

Resolution

  1. From User Interface in Salesforce Setup, enable the "Set Audit Fields upon Record Creation and Update Records with Inactive Owners" User Permission organization-wide permission.
  2. In Salesforce Setup, grant the Update Records with Inactive Owners system permission to the user profile performing the restore operation by doing the following:
    • From the profile, click System Permissions > click Edit > select the checkbox next to Update Records with Inactive Owners > click Save.
  3. Run the restore operation again.

For more information, see Salesforce knowledge article 000334139.

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