Performing a Salesforce restore operation on a Salesforce object that is cross-referenced by another object produces an error.
Symptoms
A restore operation on a Salesforce object that is cross-referenced by another object does not run and the following error appears:
INSUFFICIENT_ACCESS_ON_CROSS_REFERENCE_ENTITY
Causes
The error is typically caused by one of the following scenarios:
The object record does not have a valid record type ID.
The user running the restore operation does not have access to the record type of the object record.
The user that an object is assigned to does not have access to the record type of the object record.
The user performing the restore operation does not have sufficient read/write permissions for the objects that are being restored.
Resolution
In Salesforce, verify the following:
Verify the object record has a valid record type ID.
Verify the assigning user's profile has access to the record type of the object record.
Verify the user being assigned the object record has access to its record type.
Verify the user performing the restore operation has read/write permissions for the objects that are being restored.