Error Code: [153:3] Salesforce backup failed with error INVALID_SSO_GATEWAY_URL

Article ID: 68229

Article Type: Troubleshooting

Last Modified:

When you connect to Salesforce or perform a backup or restore, you receive an "INVALID_SSO_GATEWAY_URL" error message.

Symptoms

When you connect to Salesforce or perform a backup or restore, you receive the following error message: Error Code: [153:3] INVALID_SSO_GATEWAY_URL; the single sign on gateway url for the org is invalid

Causes

Single sign-on (SSO) is enabled for Salesforce, but the user is using username-password authentication to log into Salesforce.

Resolution

In Commvault or Metallic, use OAuth authentication:

  1. From the navigation pane, go to Protect > Application > Salesforce. The Salesforce page appears.
  2. In the Name column, click the Salesforce app. The app page appears.
  3. On the Configuration tab, in the Account settings section, beside User account, click the pencil button . The Account details dialog box appears.
  4. Select OAuth (Recommended). The Connected App credentials and Login with Salesforce buttons appear.
  5. Beside the Connected app credentials, select the existing connected app credentials or click Click new to add new credentials. If the Connected app credentials are not visible, ignore this step.
  6. Click Login with Salesforce.
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