Could not connect to the database!...FATAL: SSL connection is required

Article ID: 68533

Article Type: Troubleshooting

Last Modified:

When you connect to a sync database or perform a backup or restore operation, you receive a "Could not connect to the database!...FATAL: SSL connection is required" error message.

Symptoms

When you connect to a sync database or perform a backup or restore operation, you receive the following error message: Could not connect to the database! Cannot create PoolableConnectionFactory (FATAL: SSL connection is required. Please specify SSL options and retry.)

Causes

The database that is configured as a sync database for your Salesforce org has TLS enabled, but the sslmode connection setting is not enabled.

Resolution

From the Command Center, add the sslmode connection setting to the access node by doing the following:

  1. In the search box, type/additionalsettings, and then press EnterThe Additional settings page appears.
  2. From the Setting list, select Entity.
  3. Click Add setting. The Add setting dialog box appears.
  4. In the Enter setting name box, enter sf_dbConnectionProperties.
  5. From the Select entities list, select the server that acts as the access node for Salesforce.
  6. For 11.22 and more recent versions, in the Enter text box, enter &sslmode=require for the setting.
  7. Click Add.
  8. Click Apply.
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