Request to update Client name changes CommServe name.

Article ID: 53962

Article Type: Troubleshooting

Last Modified:

User changing a Client hostname via CommCell Console results in CommServe hostname being changed.

Symptoms

When you change the clients hostname the change is actually accepted with no errors. On the commserve you see this in evmgrs log:

1204 790 06/23 14:01:00 ### ::onMsgGUIData() - msgType = [8001-MsgSetClientProperties], size [ ], #elems [ ], sent from socket [ ].

1204 790 06/23 14:01:00 ### ::onMsgGUIData() - sent by user [ ] from [ ].
1204 790 [date/time] ### ::onMsgGUIData() - enter cs for appmgr with mutex AppMgrCS_3162
1204 790 [date/time]  ### IsClientVersionLessThan() - Parameters passed clientNetHostName [ ], versionToCompare [ ]
1204 790 0[date/time] ### GetVMPMList::runNameChangeOpOnPhyNodesOfVM() - Client [ ] is not a virtual client
1204 790 [date/time]  ### ::onMsgGUIData() - exit cs for appmgr with mutex AppMgrCS_3162

CommServe name change is identified when Commvault services are recyled on the CommServe and they fail to start.

Causes

Request to update Client name caused a DNS name collision. A DNS name collision occurs when users unknowingly access a name that has been delegated in the public DNS  when  the  user’s  intent  was  to  access  a  resource  identified  by  the  same  name  in  a  private network. The collision causes the new name in the private network to resolve to IP address 127.0.53.53 – an IP address used for such situations by ICANN, the organization who coordinates the Internet’s global domain name system.

The 127.0.53.53 IP address returned by the request to update the client hostname is instead intercepted by the CommServe loopback interface causing the name change request to be performed on the Commserve machine itself.

Resolution

On the CommServe host:

  1. Enter regedit in the Desktop's Start Menu's Search box and press return.

  2. Open Registry Key *HKLM\SOFTWARE\CommVault Systems\Galaxy\Instance001\Machines*

  3. Double-click on Registry Value sHOSTNAME and for Value data enter the actual hostname of the CommServe host.

  4. Click OK to save

Update the client hostname using a different hostname than the one causing this issue.

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