Error Code [82:128] Network receive failed: "message"

Article ID: 54100

Article Type: Troubleshooting

Last Modified:

For Exchange 2010 and later, database backup failed with the network received failure message Error Code: 82:128.

Symptoms

Applies to: Exchange 2010 and later

The database backup fails with following network received failure message:

Error Code: 82:128

Errors similar to the following appear in the extidbbackup.log on the Exchange server. This log file is located in software_installation_path\Log Files

1234 1d58 10/22 10:01:00 1234 ** CVSession::receiveMessageInt(...): - RemoteHost=mediaagent.com. - RemoteProcess=cvd.exe. - checkDataWaiting () failed. Error=9000022. Error code 9000022 translates to: [...]:Remote machine [...]. The socket connection was lost unexpectedly. MyIoctl returned 0 bytes waiting. Check Network Connectivity.

In addition, the following error might appear in the extimbstartbackup.log on the CommServe host specifically for DAG backups.

1234 1d58 10/22 11:01:00 1234 ** CVSession::receiveMessageInt(...): - RemoteHost=exchangeserver.com. - RemoteProcess=extidbbackup.exe. - checkDataWaiting () failed. Error=9000022.

Causes

This error might occur because there is an idle connection during the backup job. There are two cases that might cause the error.

  1. The Exchange database backup occurred during an integrity check between the MediaAgent and the Exchange server.
  2. Exchange DAG backups occurred between the Exchange server and the CommServe host.

The Exchange database backup opens a pipeline between the MediaAgent and the Exchange server.

Many environments have network settings in place that will disconnect a connection if it is idle for more than a certain period of time. If the connection fails, the job goes into a pending state and the error occurs.

Resolution

Configure a one-way firewall between the servers that lose the connection. This creates a persistent pipeline that sends live messages continuously at regular intervals.

The procedure for this resolution refers to the MediaAgent and Exchange servers, but substitute the CommServe host for the MediaAgent if the disconnect is occurring between the CommServe host and the Exchange servers.

If the connection is lost between the MediaAgent and the Exchange server, configure the firewall between those components.

If the connection is lost between the CommServe host and the Exchange server, configure the firewall between those components.

For more information, see Setting up a One-Way Firewall (Client to CommServe) Using Advanced Firewall Settings.

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