Backup Error: Completed with one or more errors

Article ID: EXDB0005 Backup jobs for the Exchange Database Agent are displayed as "Completed w/ one or more errors" in the Job History viewer.

Symptom

The Job History viewer displays backup jobs from the Exchange Database Agent as:

Completed w/ one or more errors

Cause

API Backup (Exchange Legacy)

  • At least one database is found to be dismounted and the remaining databases are backed up successfully.
  • One database failed to backup because of Exchange streaming API failure or network failure and we cannot recover from those errors for the legacy backup.

VSS Backup

  • The database failures are attributable to Exchange, such as the Exchange Information Store server is down, the Exchange VSS Writer is not in a stable state, and so on.

Exchange 2010 and Later

  • Backup from one node that fails, while the backup from another node succeeds.
  • Any database that is being backed up is dismounted.
  • Other database failures that are attributable to Exchange, such as the Exchange Information Store server is down, the Exchange VSS Writer is not in a stable state, and so on.

Resolution

API Backup (Exchange Legacy)

  • If a database is dismounted, remount the database, and then run the job again.
  • If a networking failure occurs, fix the networking error, and then run the job again.

VSS Backup

  • If the failure is attributable to Exchange, open the Exchange Management Console and check for any failures. In addition, make sure that the databases are mounted and that the VSS writers are in a stable state. Then run the job again.

Exchange 2010 and Later

  • If a backup from one node completes but fails on another node, open the Exchange Management Console and check for replication failures. Resolve any failures with replication. In addition, resolve any network communications issues between nodes, if there are any. Then run the job again.
  • If a database dismounts, remount the database, and then run the job again.
  • If the failure is attributable to Exchange, open the Exchange Management Console and check for any failures. In addition, make sure that the databases are mounted and that the VSS writers are in a stable state. Then run the job again.