Error code [28:34] Could not open the Exchange private message store with profile

Article ID: EXPB0001 Backup of Exchange mailboxes or folder fails using account/ profile configured in agent properties

Symptom

Logs contain entry similar to:

Error Code: [28:34] Description: Error: Could not open the Exchange private message store with profile >[ ], reason >[ ]. Please verify that this product's created profile can log on to its associated mailbox using the Exchange Client Software. If this software is not currently installed, log on to the Exchange Server using this product's Exchange Account. Source: [ ], Process: ExPubBackup 

Cause

Account used to access Exchange is not dedicated, single-use and has restrictions or conflicting permissions. Additionally, the Outlook profile used may have invalid permissions.

Resolution

  1. Verify that account used by agent to access Exchange is dedicated-single use without restrictions or extra permissions.  
  2. Verfify Outlook profile cache mode is unchecked.
  3. If error persists, add Addtional Setting 'CreateProcessSpecificProfile' value = 0 to Exchange agent host. This will enable use of a static profile vice a process specific profile. Default value is 1.