Loss of control process vsbkp.exe, VSS problem occurred, or FAILED_AT_PREPARE_SNAPSHOT status for writer

Article ID: 54091

Article Type: Troubleshooting

Last Modified:

VSS errors during backups.

Symptoms

Symptom1:

When using Microsoft VSS and Hyper-V with Windows 2008 R2, the Job Details Status Window shows the following message:

Error Code: 19:599
Loss of control process vsbkp.exe.

Symptom 2:

The Job Details Status Window shows the following message:

Error Code: 91:9
VSS problem occurred.

Symptom 3:

The vsbkp.log file has the following entries:

FAILED_AT_PREPARE_SNAPSHOT status for writer 'Microsoft Hyper-V VSS Writer'. code VSS_E_WRITERERROR_INCONSISTENTSNAPSHOT


CsSnapRequestor::GatherWriterStatus() - Signaling bad state returned for writer [Microsoft Hyper-V VSS Writer] engaged in backup.


CVSSClientShadow::CreateShadow() - Failed to create shadow.
CMSInfo::MountVM() - Failed to create shadow. hr=[0x80004005]
vsbkp::run() - Failed to create the shadow.Backup is failing.
vsbkp::HandleVMComplete() - Error backing up VM [SVCVMT01]


Scheduler Set pending cause [VSS problem occurred. Possible reasons include: VSS writers are in bad states; VSS writers are not visible.]::Client [ ] Application [vsbkp] Message Id [1526726665] RCID [0] ReservationId [0]. Level [0] flags [0] id [0] overwrite [0] append [0] CustId[0].

Another vsbkp.log file entry may be:

09/16 04:21:34 99380 CsVssAsync::WaitUntilDone() - Async status returned code = 0x80042313, Description = Unknown status.
09/16 04:21:34 99380 Entering [CVSSClientShadow::AbortShadow]

There will be a matching entry in the Operating System Event Logs:

Volume Shadow Copy Service error: The I/O writers cannot be flushed during the shadow copy creation period on volume . The volume index in the shadow copy set is 0. Error Details: Open[0x8000ffff, Catastrophic failure], Flush[0x00000000, The operation completed successfully.], Release[0x00000000, The operation completed successfully.], OnRun[0x00000000, The operation completed successfully.].

Causes

Cause 1:

  1. The control process may have died unexpectedly. Check the Dr. Watson log or core file to determine whether this is the case.
  2. The communication to the control process machine might be down as a result of network errors.
  3. If the machine is a cluster, it might have failed over.
  4. The machine might have rebooted.

Cause 2:

  1. VSS writers are in bad states.
  2. VSS writers are not visible.

Cause 3:

Missing Microsoft Hot Fixes, configuration, and Commvault® Software Enhancements or Patches can contribute to the problems.

Resolution

  1. Ensure that the latest Microsoft Hyper-V Service Packs, Updates, and Hot Fixes are reviewed and applied according to Microsoft's recommendations, as described in the following links:
  2. Check the DiskPart Automount Status:
  3. From the Microsoft TechNet forum, review the following discussions for additional details:
  4. For all versions, run the following command from an admin-level-elevated command prompt: vssadmin list writers > c:\writers.txt

Additional Information

For version 9.0 review the following information:

Troubleshooting - Microsoft Hyper-V Backup

For version 8.0 of the CommServe, MediaAgents and iDataAgents must be updated with SP4 or higher. All Service Packs are cumulative from Release to Manufacture (RTM).

For additional VSS troubleshooting information, review the following articles:

  1. Failed to create a VSS snapshot and it is required in order to run a system state backup. Failing the scan.
  2. Vssadmin
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