Unable to restore messages containing PNG images

Article ID: LNAR0001 PNG images are not getting restored in 8.5.2 and 8.5.3 till FP3 due to Domino side issue KB Article :http://www-01.ibm.com/support/docview.wss?uid=swg21628222 Solution: update Domino Server 8.5.3 FP3 +

Symptom

PNG images are not getting restored in 8.5.2 and 8.5.3 till FP3 due to Domino side issue

Cause

The PNG object is lost during the DXL export. The following is a sample of the corruption within the DXL. The PNG data is sent as incomplete compositeData.

 

containertype='65453' afterbegincount='180'>
UhQEAI8NAAABAAAAAAAAAAAAAAA=


yv9HADsAAAAAAAAAQmVzY2hyZWlidW5nOiBodHRwOi8vd3d3Lm5leHRldm9sdXRpb24uZGUvbmV4
dGV2b2x1dGlvbi5naWY=

The issue was due to enhancement changes to DXL introduced in 8.5.2.

PNG images are stored in a RichText field using a "IMAGEHEADER2" CD Record, which was not recognized in DXL until 8.53FP3.

Resolution

The issue is resolved in 8.5.3FP3 by SPR YLJA8JQ6RU. This SPR added recognition for the IMAGEHEADER2 CD record which represents a PNG image.


To resolve the issue the recommendation is to upgrade to 8.5.3FP3. However this will only resolve the issue for DXL exports generated after the upgrade. The upgrade will not recover the PNG image from corrupted DXL exported files.