Error Code 32:406 Client cannot use MediaAgent with old version

Article ID: MA0004 Data Protection Job goes to waiting/pending state because of inability to access storage path or media.

Symptom

Error Code: [32:406] Client cannot use MediaAgent with old version: Library [XXXXXXX], MediaAgent [XXXXXXXX], Drive Pool [DrivePool(XXXXXXXX)], Media[]:Please update the MediaAgent: Source: Process:

Cause

MediaAgent software version/service pack level is older than client software version/service pack level.  CommServe and MediaAgents should always be at the latest level. Clients can be older is some cases and operate successfully, but they cannot be newer.

Resolution

Run Check Readiness task to verify readiness and update information of Agent's software version. Use the Version information in the Client Agent's Properties to verify use of same software version and service pack level as the MediaAgent and Software. Update as necessary.