Stack-based buffer overflow vulnerability

Article ID: SEC0013 Commvault Edge, version 11 is vulnerable to a stack-based buffer overflow vulnerability.

Symptom

An unauthenticated remote attacker can execute arbitrary code with root/SYSTEM privileges.

Cause

Reported as CVE-2017-3195. A stack based buffer overflow in the Commvault Edge Communication Service (cvd) allows remote attackers to execute arbitrary code via crafted packets, exploiting weaknesses in the key exchange mechanism. Access to TCP port 8400 (by default) on the target machine is necessary to exploit this vulnerability.

Resolution

Apply and Update

Commvault has provided fixes in the latest service pack (SP7 and above) to address the vulnerability.  For Service pack 6 customers, install the latest SP6 hotfix pack.

REFERENCES

https://cwe.mitre.org/data/definitions/121.html

https://www.kb.cert.org/vuls/id/214283