Restore operation keeps running and datastore is not released: Did not find mount context for shareId

Article ID: VMW0019 When performing a Live Browse, Live Recovery, or Live Mount operation, the operation runs for a long period of time and does not release the datastore that is used for the operation.

Symptom

When a browse or restore operation uses the 3dfs server on a Windows MediaAgent or File Recovery Enabler for Linux, the operation runs for a long period of time and does not release the datastore that is used for the operation. 

The following information might appear in the fbr.log file:

IsFHValid(923) - Did not find mount context for shareId [id_value]
Handle_GETATTR3(346) - Invalid file handle given.

Cause

This issue can occur when an update starts on the machine hosting the 3dfs service (Windows MediaAgent or File Recovery Enabler) while the datastore is mounted on the ESX server. If the update process is stopped on the machine hosting the 3dfs service, the machine is unable to communicate with the 3dfs server to request the unmount for the datastore. 

A persistent recovery job can remain in the job controller for up to 24 hours; this is normal.

Resolution

To resolve this issue, clear the 3dfs cache by performing the following steps:

  1. Log on to the machine hosting the 3dfs service. 
  2. Run the following command to stop the 3dfs service: 
    killall –SIGINT 3dnfsd

    The killall command sends SIGINT to the 3dnfsd process. The 3dnfsd process captures this signal and exits gracefully.

  3. Run the following commands to clear the cache:
    cd  /opt/3dfs
    mv 3dfs 3dfs.old
    rm –rf 3dfs.old &
  4. Manually remove the datastore on the ESX server. 

In some cases, the Remove datastore operation might not show as completed on the vSphere client, as described in Removing a datastore in the vSphere Client, the Remove datastore task remains in the In Progress state (2097289). This is a cosmetic issue only; you can confirm the datastore removal in the storage view for the ESX server.