"Something went wrong": Error When You Log On to the Web Console After an Idle Session

Article ID: WEB0005 When you log on to the Web Console after an idle session, a message appears that says "Something went wrong".

Symptom

When you log on to the Web Console after an idle session, a message appears that says "Something went wrong".

When you refresh the page, you can log on.

Cause

When the Commvault Web Server reaches the idle timeout (by default, the idle timeout is 20 minutes), due to inactivity on the Web Console, the underlying process for the Commvault Web Server goes down, and clears the memory to conserve system resources.

The first visit to a Web Console application triggers the Commvault Web Server to create a new worker process, which loads the objects into the memory. Loading the objects into memory might take a few minutes, which can cause the user to experience a slow responding application, and then the error message appears during logon.

Resolution

In the IIS settings on the Web Console computer, increase the idle timeout for the console application pool.

To change the idle timeout setting, complete the following steps:

  1. On the Web Console computer, open IIS Manager.
  2. In the Connections pane, expand the server node, and then click Application Pools.
  3. On the Application Pools page, select ConsoleAppPool, and then, in the Actions pane, click Advanced Settings.
  4. In the Idle Time-out (minutes) box, enter the number in minutes, and then click OK. For example, to specify a timeout period of 3 days, set the value to 4320 minutes.