Error Code 32:406 There are not enough drives in the drive pool
Article ID: 53874
Article Type: Troubleshooting
Last Modified:
Data Protection Job goes to waiting/pending state because of inability to access storage path or media.
Symptoms
Error Code: [32:406] There are not enough drives in the drive pool:
Library [XXXXXXX], MediaAgent [XXXXXXXX], Drive Pool [DrivePool(XXXXXXXX)], Media[]:
Please check the following:
There are drives with compatible recording format to the media being written.
?There are enough available drives in the drive pool for this job. If the issue persists, please contact customer support.
Causes
Inline Copy enabled causing drive requirement to exceed available drives.
Drive Reservation causing tape to stick in drive making drive unavailable.
Max number of Storage Policy streams available less than required by job.
Avalable number of compatible media less than requried by job.
Resolution
Data path consists of MediaAgent, Library, DrivePool and Spare Media Pool. The Preferred Data path uses the MediaAgent co-hosted with the Client Agent. Running Check Readiness for the Client is the easiest way to identify any problems with the data path.
To verify each component individually:
In Job Controller, open Details and check for number of readers being used.
Open MediaAgent Properites and verify that both the MediaAgent and Index Cache states are online and ready
Open the Library Properties and verify its state is online and ready
Open the Master Drive Pool and verify the online/ready state of all drives in the drive pool. Check for offline, occupied, or reserved drives. You should have sufficient number of ready state drives to accommodate all readers needed for the job.
Correct any offline state. If drives are busy, you can suspend the job and wait until drives are not busy or let that job retry as scheduled until drives are free and the job can continue.