Error Code 28:153 The mailbox profile used by this product is invalid

Article ID: 53887

Article Type: Troubleshooting

Last Modified:

Exchange Mailbox or Public Folder iDataAgent (iDA) backups fail.

Symptoms

Backup fails with Error Code 28:153 The mailbox profile used by this product is invalid. Please try using MDBVU, Outlook or any other Exchange client to check if the profile works correctrly.

Causes

During installation, the software creates an Exchange profile on the server.  The profile is used to log on to the Exchange server for any message level Exchange backups.

A profile error can be logged when permissions are not correct for the backup account.

If backup account is 'hidden from address list' a profile cannot be created. Account cannot be hidden when profile is being created.

Occasionally the profile may become corrupt or deleted causing the login to fail.  In other cases the mailbox name of the user may change which also causes the failure.

Resolution

  1. First, verify the account being used for backups.

  2. Open the "CommCell Console" and navigate to the affected Exchange client in the "Client Computers" list.

  3. Expand the client for the appropriate Exchange iDA. (Mailbox or Public folder, whichever backups you are having issues with) and right click and select "Properties."

Note the Profile, mailbox, and user name values that are currently set here.

  1. Log on to the server with the Mailbox agent installed with this account.

If Outlook is installed on the client.

  1. Go to the control panel and double click the MAIL icon.

  2. Click on the Show Profiles Button.

  3. If the profile is not in the list, click add, if the profile is in the list, highlight it and remove it first, then hit add.

  4. Name the profile the same thing as found on the properties of the agent.  Click next for the automatic configuration to run through and then check off the manually configure server settings checkbox.

  5. Click next and then make sure if the use cached exchange mode option is checked, uncheck it and hit finish.

  6. Open the "CommCell Console."  Navigate to the Mailbox, Public Folder or Data Migrator IDA, right click and choose properties.  Make sure the profile name and mailbox name matches the profile you just created. Log off of the Exchange server.

If Outlook is NOT installed on the client.

11. Use the Microsoft® utility called Profman2 to recreate a profile for the software's backup user.  This utility can be downloaded through the following link:

Microsoft KB 228736 Profman2.exe - MAPI Profile Manager v2.0

  1. Download and extract Profman2 to a folder on your Exchange server.  Run Profman2.exe.

Profile Manager (profman) will show you any currently configured MAPI profiles for the account you are logged on as.  If the profile you saw in the Exchange iDA properties page exists, select the profile and click the X button to delete it.

  1. In Profman2 dialog window, click on the first button to create a new profile.  Enter the profile name (not mailbox) as seen in the Exchange iDA properties page and click OK.

  2. Highlight the new profile and click the icon with the bolt and nut to add services.

  3. Select MSEMS and click OK.

  4. At the MAPI profile window add the exchange server name and the mailbox name for the profile being created.

  5. Click on the check name button to verify the profile.  If the checked name differs from the Mailbox entry seen in the Exchange properties page, note the proper name so it can be update it in software.

  6. Click OK and the profile is created.  Log off of the Exchange server.

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