Error code [28:34] Could not open the Exchange private message store with profile

Article ID: 54389

Article Type: Troubleshooting

Last Modified:

Backup of Exchange mailboxes or folder fails using account/profile configured in agent properties.

Symptoms

Logs contain an entry similar to:

Error Code: [28:34] Description: Error: Could not open the Exchange private message store with profile >[ ], reason >[ ]. Please verify that this product's created profile can log on to its associated mailbox using the Exchange Client Software. If this software is not currently installed, log on to the Exchange Server using this product's Exchange Account. Source: [ ], Process: ExPubBackup

Causes

The account used to access Exchange is not dedicated, single-use and has restrictions or conflicting permissions. Additionally, the Outlook profile used may have invalid permissions.

Resolution

  1. Verify that the account used by the agent to access Exchange is dedicated-single use without restrictions or extra permissions.
  2. Verify Outlook profile cache mode is unchecked.
  3. If the error persists, add Additional Setting 'CreateProcessSpecificProfile' value = 0 to Exchange agent host. This will enable the use of a static profile versus a process specific profile. The default value is 1.
1 Commvault Way, Tinton Falls, NJ 07724 Sitemap | Legal Notices | Trademarks | Privacy Policy
Copyright © Commvault | All Rights Reserved.