Error code [28:336] No mailboxes/folders were found to backup

Article ID: 54409

Article Type: Troubleshooting

Last Modified:

Exchange mailbox archive or backup operation fails to find any mailboxes to backup.

Symptoms

ExMBBackup,log contain:

Error Code: [28:336] Description: No mailboxes/folders were found to backup. Check the subclient content from the CommCell Console.======= Source: [], Process: ExMBBackup

Causes

There are numerous possible causes, but most fall into two categories:

Most reported failures occurred after a migration event. One failure occurred due to Anti-Virus interference.

Additionally, this error has occurred when there was no access to the the domain controller with the Active Directory list of users.

Resolution

Consult documentation and verify the Exchange user used to access mailboxes for backup is properly configured and has the appropriate permissions.

Verify the exchange server(s), database(s), and mailboxes being backed up are in the proper location and state for backup.  If a migration has recently occurred, check the expected migration state. If there is a possibility that thre are no mailboxes to discover you can add the additional setting AllowEmptySubclient to avoid the error.

For achiving, if you want to backup/archive messages that exist outside of the journaling mailbox, that is, messages that were sent and/or delivered before the journal archives began or mailboxes configured using Premium Journaling, then you add the additional Setting FindAllMailboxes to archive all maiboxes.

Check communication access between all Commvault components, the exchange servers, and Domain controllers.

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