Error Code [68:183] Detected a conflicting version of software on the machine
Article ID: 54411
Article Type: Troubleshooting
Last Modified:
Installation of software fails on new or existing client
Symptoms
Install log shows:
Error code: 68:183. Error description: Detected a conflicting version of software on the machine, skipping this client. Remove all software versions from the client and re-submit the job, or use allow multiple instances to install a new instance of the software.
Causes
Software already installed on client or uninstallation failed to remove all software and registry entries.
The intent of install was for multi-instance and multi-instance requirements not properly configured.
Resolution
If new or re-install:
Follow instructions contained in documentation to uninstall existing software.
On Windows hosts,
Check Program Files and Program Data folders for Commvault subfolders. Remove all Commvault subfolders. Note: Program Files is the default location. Search all volumes for Commvault folder to locate and delete existing folders.
Check Computer\HKEY_LOCAL_MACHINE\SOFTWARE registry key for CommVault Systems, GalaxyInstallerFlags, or GalaxyRemoteInstall Keys. Create an export of the registry then remove these keys from the registry.
On Unix-like hosts,
Check for and delete /etc/CommVaultRegistry folder.
Check for and delete /opt/commvault folder. Note: This is the default location. The software may be installed in another folder. Search the volumes for commvault to locate and delete all commvault folders.
If multi-instance install:
Follow instructions contained in documentation to configure/enable multi-instance installation.