VMware backup and restore operations fail with error opening virtual machine disks

Article ID: 63206

Article Type: Troubleshooting

Last Modified:

VMware backup and restore operations fail because the incorrect transport mode was used or no transport mode could access the virtual machine (VM) disks.

Symptoms

A backup or a restore operation for a VMware VM fails and the following error message appears: Error opening the disks for virtual machine [VMName].  Verify that the correct transport mode is selected.

Causes

The access node cannot open the virtual disks for a VM.  This might happen when the wrong transport mode is selected or when the access node cannot use any of the transport modes to open the virtual disks. By default, the transport mode is automatically detected, but you can manually configure a specific transport mode. The various transport modes should be used in the following situations:

For more information about each transport mode, in the Commvault documentation, see Transport Modes for VMware.

Resolution

The resolutions vary based on the type of transport mode required for the situation. If the software was forced to use a specific transport mode during the backup or restore operation, select Auto as the transport mode to allow the access node to detect the appropriate mode. For instructions, see Configuring Transport Modes for VMware.

NBD/NBDSSL

For NBD mode and NBDSSL mode, the access node must communicate directly with the NFC service on the ESXi host. While the access node performs many other operations on the vCenter Server, which in turn communicates with the ESXi host, the operation to open the VM disks is an exception. The access node resolves the hostname of the ESXi host as it is known by vCenter, and then communicates with the NFC service over port 902. To resolve the error that occurs when trying to open VM disks, perform the following operations:

Hotadd

For Hotadd mode, examine the ESXi host that the access node is running on and the VM configuration on the access node. To resolve the error that occurs when trying to open VM disks, perform the following operations:

SAN

For San mode, examine the disks/LUNs that are zoned to the access node: To resolve the error that occurs when trying to open VM disks, perform the following operations:

NAS

For NAS mode, examine the filer to verify that the access node has permission to read/write from the share that serves as the datastore.

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