Live Recovery or Live Mount error: Unable to mount the media as a datastore.

Article ID: 67989

Article Type: Troubleshooting

Last Modified:

Live Recovery and Live Mount operations might fail because the ESX server cannot communicate with the Commvault NFS (3DFS) service on the MediaAgent.

Symptoms

The Live Recovery or Live Mount restore operation fails with the following error message:

Unable to mount the media as a datastore. [3DFS_SERVER] NFS mount [3DFS_SERVER]:/0_[ESX_SERVER] failed: Unable to connect to NFS server. Source: [VSA Proxy/Access Node], Process: vsrst "

The following error displays in the vsrst.log file:

15808 4d4   06/18 22:40:38 ##### CVMWareInfo::_Mount3dFSDatastoreOnHost() - Mounting 3DFS datastore [3DFS_GX_BACKUP_0_<3DFS_SERVER_CLIENTNAME>_<ESX_SERVER>] on host [ESX_SERVER]

15808 4d4   06/18 22:40:38 ##### CreateNASDatastore() - dsNfsName: 3DFS_GX_BACKUP_0_<3DFS_SERVER_CLIENTNAME>_<ESX_SERVER>

15808 4d4   06/18 22:40:38 ##### CreateNASDatastore() - SOAP : PlatformConfigFaultFault

15808 4d4   06/18 22:40:38 ##### CreateNASDatastore() - PlatformConfigFaultFault Exception - [An error occurred during host configuration.] - [<3DFS_SERVER_CLIENTNAME>] - [NFS mount <3DFS_SERVER_CLIENTNAME>:/0_<ESX_SERVER> failed: Unable to connect to NFS server.]

Causes

The firewall prevents the ESX server from communicating with the 3DFS server, which serves the NFS Remote Procedure Call (RPCs) during live mount or live recovery of the VM.

Resolution

If a firewall is in place, open port 2049 to enable communication between the ESX server and the 3DFS server. For more details, see Additional Port Requirements for 3dnfs Services.

1 Commvault Way, Tinton Falls, NJ 07724 Sitemap | Legal Notices | Trademarks | Privacy Policy
Copyright © 2022 Commvault | All Rights Reserved.