The mounting of an Oracle ASM database snapshot fails at the "alter diskgroup [disk_group_name] mount" step

Article ID: 68005

Article Type: Troubleshooting

Last Modified:

The mounting of a snapshot for an Oracle database on ASM fails when a backup copy job or a restore job tries to mount a snapshot. This failure can also occur when a user uses the GUI to initiate an operation that includes mounting a snapshot.

Symptoms

The mounting of the Oracle ASM database snapshot fails when the SQL "alter diskgroup [disk_group_name] mount" step is issued.

The following Oracle errors might also be included in the logs:

Causes

The Commvault software was installed on a separate logical volume. The mount directory that is used for this logical volume mount does not have 755 permissions at all levels under the root (“/”) path.

Resolution

1. Stop Commvault services:

commvault stop




2. Unmount the Commvault software installation volume. For example:

unmount /Commvault/




3. Change folder permissions to 755 for all folder levels in the mount point path. For example, if the mount point is /opt/backup/commvault, then set 755 permissions on /opt, /opt/backup, and /opt/backup/commvault. For example:

chmod 755 /Commvault




4. Mount the Commvault software installation volume. For example:

mount /Commvault




5. Start Commvault services:

commvault start




6. Verify that the Commvault-installed OS group also belongs to the grid user.

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