OneDrive for Business backup may fail with error "The provided client secret keys are expired"

Article ID: 68488

Article Type: Troubleshooting

Last Modified:

OneDrive for Business backups are failing because the client secret (application secret) is expired.

Symptoms

OneDrive for Business backups are failing with the following error:

(ERROR_ERRORS_ENCOUNTERED))-Exception: System.AggregateException: One or more errors occurred. ---> Microsoft.IdentityModel.Clients.ActiveDirectory.AdalServiceException: <AAD_ID>: The provided client secret keys are expired. Visit the Azure Portal to create new keys for your app, or consider using certificate credentials for added security: https://docs.microsoft.com/azure/active-directory/develop/active-directory-certificate-credentials

Causes

The Azure client secret (application secret) used to configure the app is expired.

Resolution

  1. In the Azure portal, create a new secret for the Azure application. After the secret is created, copy the value, and then update the application secret in the Metallic console. For information about creating a secret in the Azure portal, see Create a new application secret on the Microsoft website.
  2. In the Metallic console, manually run a backup operation.
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