Error Code: [39:7] NDMP connection to host [<hostname>] failed. Please verify the NDMP Server can be reached on this host using your current IPV4/IPV6 settings on MediaAgent. Source: commsrv, Process: NasBackup
Article ID: 77189
Article Type: Troubleshooting
Last Modified:
This article provides guidance for resolving error 39:7 (NDMP connection to host hostname failed...) and the possible causes of this error.
Symptoms
A backup or a restore operation for a NAS NDMP client fails with the following error message:
Error Code: [39:7] NDMP connection to host [<hostname>] failed. Please verify the NDMP Server can be reached on this host using your current IPV4/IPV6 settings on MediaAgent. Source: commsrv, Process: NasBackup
Causes
The MediaAgent is unable to connect to the file server being backed up or the file server being restored to.
The MediaAgent for a job is chosen as follows:
In a typical NDMP configuration, the MediaAgent is chosen from the plan or the storage policy associated with the backup.
Alternatively, an access node can also be associated with the NDMP agent under a NAS client. Such a configuration is useful when the plan or the storage policy MediaAgents do not have access to the file server or have lower performance access. In this configuration the MediaAgent is chosen from the access node configuration when performing the backup or restore operations.
In a Metallic configuration, the Metallic backup gateway can be set as the access node on the NDMP agent under the NAS client. This gateway is chosen as the MediaAgent to communicate with the file server.
Resolution
Verify connectivity between the MediaAgents associated with the file server.
From the Command Center
From the navigation pane, go to Protect > File Servers.
Click the file server.
The file server properties page appears.
Under Protocols, click NDMP.
On the Configuration tab, in the Access Nodes section, verify if access nodes have been set.
If access nodes are required, click Edit, and then add access nodes to the list.
In the NDMP properties section, click Edit, and then in the dialog box, click Preview.
The detection will be done using a MediaAgent with the following priority:
a. If access nodes are set, the first access node from the list will be used.
b. If the default subclient has a storage policy selected, the first MediaAgent from the data paths on the primary copy will be used.
c. Otherwise, the CommServe will be used.
From the CommCell Console
From the CommCell Browser, expand Client Computers > NAS client.
Right-click NDMP, and then click properties.
The NDMP
properties dialog box appears.
On the Proxy MA tab, verify if access nodes have been set.
If access nodes are required, select the MediaAgents from the Available Proxy MediaAgents list, and then click Add.
On the General tab, click NDMP Properties.
The NDMP Server Properties dialog box appears.
Click the Detect button.
The detection will be done using a MediaAgent with the following priority:
a. If the Detect MediaAgent option is set on the dialog box, that specific MediaAgent will be used.
b. If access nodes are set on the Proxy MA tab, the first access node from the list will be used.
c. If the default subclient has a storage policy associated, the first MediaAgent from the data paths on the primary copy will be used.
d. Otherwise, the CommServe will be used.
Any error when logging on to the file server will be displayed in an error dialog. If an error appears that a connection could not be made to the file server, verify the connectivity from MediaAgents in the access node list or on the plan/storage policy, verify that the file server host name (as displayed in the NDMP Server Hostname field) is reachable, and that the NDMP port (usually 10,000, but can be modified in the Listen Port field) is open from the MediaAgent to the file server.