Error Code: [39:424], [39:501] Description: Client [<client name>] was unable to connect to the tape server [<MediaAgent address>] on port <port number>]. Please check network connectivity. Source: <mediaagent name>, Process: NasBackup

Article ID: 77226

Article Type: Troubleshooting

Last Modified:

This article provides guidance for resolving errors 39:424 and 39:501 (The Client was unable to connect to the tape server on port number...) and the possible causes of this error.

Symptoms

A backup or a restore operation for a NAS NDMP client fails with the following error message:

Error Code: [39:424] Description: Client [<client name>] was unable to connect to the tape server [<MediaAgent address>] on port <port number>]. Please check network connectivity. Source: <mediaagent name>, Process: NasBackup

Error Code: [39:501] description: Client [<client name>] was unable to connect to the tape server [<MediaAgent address>] on IP(s) [<IP address>] port [<port number>]. Please check the network connectivity. Source: <mediaagent name>, Process: NasBackup

Causes

When you run an NDMP backup or a restore job, a MediaAgent is chosen to run the job - this MediaAgent was able to connect to the file server to start the backup or a restore operation, but the connection for data transfer could not be established from the file server to the MediaAgent. Potential causes for this error are:

The NDMP control connection from the MediaAgent to the file server used to start the backup or a restore job typically uses the file server port 10,000 (configurable on the client NDMP properties dialog box) – this connection has succeeded so this port is open outgoing from the MediaAgent to the file server. For the data transfer, an additional connection is made from the file server to the MediaAgent. The MediaAgent will listen on open ports in the firewall configuration for this incoming connection from the file server. If no ports are configured in the firewall configuration or all configured ports are in use, any port on the MediaAgent will be used and the connection from the file sever to the MediaAgent might not succeed.

Resolution

  1. If there is a firewall between the file server and the MediaAgent, verify that ports are open in the firewall. A range of ports must be open to handle parallel NDMP jobs. For more information about NDMP firewall configuration, see Configuring a Firewall Between a File Server and MediaAgent. For more information about port requirements, see Port Requirements for Commvault.
  2. Check the file server side routing – file server vendor specific. Check the file server configuration (i.e., the routing tables) to verify that it is configured to be able to access the MediaAgent address. For NetApp file servers, the NetApp cluster will choose an interface based on     the vserver ndmp “preferred interface role” setting which defaults to 1.intercluster 2.cluster-mgmt 3.node-mgmt.
  3. If the incorrect MediaAgent address is used, consider adding a data-interface-pair (DIP). A MediaAgent might have several interfaces on different subnets. For the data transfer, the MediaAgent will listen on all interfaces for the incoming connection from the file server, and the file server must try each interface in turn until one succeeds. The connection from the MediaAgent to the file sever to start the job succeeded so there must be a valid interface between the MediaAgent and the file server. To specify a specific MediaAgent interface to use for the data transfer, you can use a DIP. For more information about configuring a dedicated backup network using DIPs, see Configuring a Dedicated Backup Network Using Data Interface Pairs.
  4. For NetApp file servers, add an interface to the cluster node which can connect to the MediaAgent.~~~~
  5. If an incorrect MediaAgent has been chosen, confirm the NAS client configuration. The MediaAgent for a job is chosen as follows:
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