Error Code: [39:479] NDMP Server [<NAS client>] reported the following error: [DUMP: Error: Message from Write Dirnet: Interrupted system call] while backing up path [<subclient content path>]. This indicates that the NDMP data connection is terminated. Please check the network connectivity.
Article ID: 77417
Article Type: Troubleshooting
Last Modified:
This article provides guidance for resolving error 39:479 (NDMP Server *NAS client* reported the following error: [DUMP: Error: Message from Write Dirnet: Interrupted system call] while backing up path * path*...) and the possible causes of this error.
Symptoms
A backup operation for a NAS NDMP client fails with the following Job Pending Reason:
Error Code: [39:479] NDMP Server
[<NAS client>] reported the following error: [DUMP: Error: Message from
Write Dirnet: Interrupted system call] while backing up path []. This indicates that the NDMP data connection is terminated.
Please check the network connectivity.Source:
<MediaAgent>, Process: NasBackup
Causes
The NetApp file server was unable to send data to the MediaAgent. The data socket connection from the file server to the MediaAgent completed successfully, but the data transfer on that socket failed. Possible causes include:
Firewall configuration between the file server and the MediaAgent does not have open ports or has too few open ports.
The network between the file server and MediaAgent is not reliable.
Resolution
If there is a firewall between the file server and the MediaAgent, verify that ports are open in the firewall. A range of ports must be opened to handle parallel NDMP jobs. For more information about NDMP firewall configuration, see Configuring a Firewall Between a File Server and MediaAgent. For more information about port requirements, see Port Requirements for Commvault.
Check the network equipment (switches, ports) between the file server and the MediaAgent.
A network trace may be needed to determine where the socket disconnect is happening.