Setup failed to execute WMI query. This error occurs when WMI is not functioning properly.

Article ID: 77487

Article Type: Technical Reference

Last Modified:

Issue

During the upgrade or installation of a Windows client, the error "Could not check the running state of process [sidb_80.exe]. We think the process is running" is returned.

Install.log

Waiting for all dedupe processes to shut down ...
Reading Installconfig Property: DedupProcesses Values:sidb2.exe, sidb2_80.exe, sidb.exe, sidb_80.exe
Could not get the running process information from folder [*:\Program Files\CommVault\Simpana\]. Exception: Not found
Could not get information for process [sidb2.exe] Running from folder [*:\Program Files\CommVault\Simpana].
Could not check the running state of process [sidb2.exe]. We think the process is running
Could not get the running process information from folder [D:\Program Files\CommVault\Simpana\]. Exception: Not found
Could not get information for process [sidb2_80.exe] Running from folder [*:\Program Files\CommVault\Simpana].
Could not check the running state of process [sidb2_80.exe]. We think the process is running
Could not get the running process information from folder [*:\Program Files\CommVault\Simpana\]. Exception: Not found
Could not get information for process [sidb.exe] Running from folder [*:\Program Files\CommVault\Simpana].
Could not check the running state of process [sidb.exe]. We think the process is running
Could not get the running process information from folder             [*:\Program Files\CommVault\Simpana\]. Exception: Not found
Could not get information for process             [sidb_80.exe] Running from folder [*:\Program Files\CommVault\Simpana].
Could not check the running state of process [sidb_80.exe]. We think the process is running
Warning: Dedupe processes are running for this instance. Asking user to wait or exit the upgrade.
Message: There are dedupe processes running for this instance. Click Yes to wait for them to go down or No to exit.
UserAnswer: Yes
User selected: Wait
Reading Installconfig Property: DedupProcesses Values:sidb2.exe, sidb2_80.exe, sidb.exe, sidb_80.exe
Could not get the running process information from folder [*:\Program Files\CommVault\Simpana\]. Exception: Not found



Cause

The Commvault software uses a WMI query to gather information during the installation phase. The issue caused by WMI not giving Commvault software the result is due to corruption. To confirm, manually run the WMI query below in PowerShell to see the result.

Get-WmiObject -Query "SELECT ProcessId, ExecutablePath, CommandLine FROM Win32_Process"

If the result is shown as like in the below example, then WMI needs to be repaired or rebuilt. file

Resolution

  1.  In an elevated command prompt run "winmgmt/verifyrepository", if the repository is not corrupted, a "WMI repository is consistent" message will be returned.
  2. If the repository is inconsistent, run "net stop winmgmt" and press Enter.
  3. In Windows Explorer, navigate to C:\ windows\system32\WBEM\ and rename the folder named "Repository" to something else, ex. RepositoryOLD.
  4. Restart the machine and in the cmd prompt run "net stop winmgmt"
  5. Type "winmgmt /resetrepository" which results in the "WMI" Repository has been reset" message and reboot the machine again.
  6. Run "winmgmt /verifyrepository" in PowerShell again to make sure the WMI is consistent.
  7. Resume\restart the Commvault installation.
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