Cleaning up resources after Amazon EC2 instance or backup deletion

Article ID: 82207

Article Type: Troubleshooting

Last Modified:

In certain cases, snapshots for Amazon EC2 instances that are intended to be temporary might be retained. You can delete these snapshots.

Amazon EC2 snapshots might be retained in the following cases:

Symptoms

In certain cases, snapshots for Amazon EC2 instances that are intended to be temporary might be retained.

Causes

In certain cases, snapshots for Amazon EC2 instances that are intended to be temporary might be retained.

When an EC2 instance is deleted from a Commvault VM group, the instance is not tracked by Commvault and any snapshots that were created before the instance was deleted are not tracked by Commvault. Thus, Commvault cannot clean up the snapshots, and manual cleanup is required.

Resolution

To find and delete the snapshots, you can search for tags that Commvault uses to identify resources that it creates.

  1. In the AWS Console, search for the following Commvault-created resources:
    • AMIs that have the following tag:
      • Key: Name
      • Value: CV_CBT_Snap
    • Changed Block Tracking (CBT) snapshots that have the following tag:
      • Key: Name
      • Value: CV_CBT_Snap

The following additional tag on the AMI gives information about the instance that this AMI was created from:     - Key: GX_BACKUP_     - Value: instance_ID

  1. If the instance was terminated or removed from an Amazon EC2 VM group, delete the corresponding AMI and its snapshots.
1 Commvault Way, Tinton Falls, NJ 07724 Sitemap | Legal Notices | Trademarks | Privacy Policy
Copyright © 2022 Commvault | All Rights Reserved.