Exchange Online backups fail with "Cannot open folder TeamsMessagesData. [Not allowed to access Non IPM folder.]"

Article ID: 82840

Article Type: Troubleshooting

Last Modified:

During a Microsoft 365 backup job for Exchange Online, you might encounter the following failure:

Cannot open folder TeamsMessagesData. [Not allowed to access Non IPM folder.]

Symptoms

Exchange Online backups might fail to process all mailboxes. Jobs might fail with "Error enumerating messages in one or more folders." In the failed items list, you see the following error message for each mailbox: [Not allowed to access Non IPM folder].

Causes

During an Exchange Online backup using Commvault, EWS APIs are used to request the properties of all mailbox folders, including legacy folders, such as TeamsMessageData.

Microsoft recently made changes to limit access to 'TeamsMessageData' folder through the EWS APIs.

Resolution

The following Maintenance Release packages will resolve this issue: 

Commvault Platform Release
2022E (11.28) Maintenance Release 11.28.111 or higher
2023E (11.32) Maintenance Release 11.32.48 or higher
2024 (11.34) This is present in all versions of Feature Release 34
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